Adding a LTO drive to Cortex workstation

Just wanted to ask if anybody has added a LTO5 tape drive directly into a Cortex workstation? Either internally or externally running SAS? I am running an HP z800 with an HP HBA SAS adapter (P212) and a Quantum LTO5 drive and no matter what combo of drivers and software I cannot get it to show up. I can see the drive is attached through ATTO software but of course cannot do anything with it there.

I was hoping to use the copy function to write LTFS straight to a drive. Would save us a bit of time.

Any advice is greatly appreciated.


@galakanokis Is it not showing up at all in Windows or do you just mean you can’t “see” it in the CORTEX Copy tool.

We do have a number of people writing to LTO via LTFS, so this should definitely be a solvable problem.

You’ve probably already tried this, but I found some documentation on Quantum’s site that details [how to mount an LTFS-formatted LTO drive as a Windows drive letter] ( (which will allow CORTEX to see it) using their [LTFS for Windows] ( software.

There’s a note “Windows version 2.2.1 only works with Model B Drives” so maybe you have a different model drive?

Drive doesn’t appear in Windows so not able to select it in Cortex.

I have gone through that document and I do have the driver and software. My guess so far is the drive firmware (LTO) might not be up to date but I have not found a way to upgrade if I cannot connect.Might have to mount it on Linux first and see what that gets me.

It won’t show up in Windows Explorer until you have the drivers installed, LTFS installed and then add a drive letter to it.

Is it showing up in the Device Manager though?

No, not in device manager.

I have the tape drive driver but no way to install. Missing something here. Maybe the wrong driver. Listed as Ultrium driver for 64bit windows but it does not list 7. Good for NT systems.

I need to look again…

It’s always good to put this out in public because as soon as you do you figure out that you’re an idiot and solve the issue. It was under other devices, in Device manager. Drivers are now loaded and drive shows up in the LTFS software. Thanks for the sounding board everyone.


Even better when others can find the solution next time around! How did you end up fixing it?

1 Like

In Device Manager I never thought to look under Other Devices in the tree. There I found the LTO drive and was able to add the drivers there. Just not looking in the right places for the device.

I still get an error in LTFS configuration regarding the HBA not supporting the transfer size (512KB) not sure what that is but the drive is there at least.

1 Like

I don’t recall seeing that transfer size issue before, but let us know if you sort that out or not after you have a chance to look into it now that you’re past that other hurdle.

Transfer size was a memory issue on the HBA card, exchanged it for another one and all good to go, works like a charm.