Having issues encoding 6 or 8 ch audio to H.264


i have not tried the BluRay yet but i did attempt to create h.264 with both 4 & 6 channels of audio.
The 4 channel version went fine but the 6 channel failed out with a CohogRender error.
I used the same source file for both versions 23.98 ProRes444 with 8 channels of audio.
running on cortex v1.5.1-b4362

The 4 channel version of the file opens fine in QT player and AMA links in Avid but will not open in DVS Clipster version or version 5.9 very strange.

I just ran a test and was able to encode to 2, 4, 6, and 8 channels to both an H.264 mp4 file and an H.264 .mov file. Checked them back in Cortex and they play fine, except in the case of 6 and 8 channels, I don’t see much going on on channel 4 where the LFE would normally be, but my test file just has a 2-pop on each channel so I’m not sure what to expect there. In any case, not crashing…

Can you email us the log files after the cohogrender crash to we can take a closer look?

i’m sending you the files via Faspex now

OK, I can reproduce the issue with the sample you provided. This is what I see in the log:

"0","CohogRender","Error","CohogRender//Execute(0): >>>>>>>>>>>>>>>> AUDIO ENCODER THREAD DIED ON AN EXCEPTION: EncodeAudio failed, returned 2","","05-16-2014 15:01:42.654","3364","12","270163377093","RETINA01"
"0","CohogRender","Error","CohogRender//Execute(0):    at AacEncoder.ManagedApi.AacEncoder.Encode(AudioBuffer sourceBuffer)
at Render.Core.Encoder.EncodeAudio(AudioBuffer sourceAudioBuffer)
at Render.Core.RenderEngineForEncoding.<StartAndWait>b__5()","","05-16-2014 15:01:42.654","3364","12","270163378484","RETINA01"
"0","CohogRender","Error","CohogRender//Main(0): (E1) Close failed, returned 2","","05-16-2014 15:01:42.681","3364","1","270163444893","RETINA01"
"0","CohogRender","Error","CohogRender//Main(0): Stack Trace:    at Render.Core.RenderEngineForEncoding.StartAndWait()
at CohogRender.Program.StartRendering(Stopwatch stopwatch)
   at CohogRender.Program.Main(String[] args)","","05-16-2014 15:01:42.681","3364","1","270163445561","RETINA01"

Will dig deeper and let you know what we find.

Dave, I know you guys are still looking into this but i tried another test today with version 1.5.1b4408.
same results as before 6 channels causes a cohog crash.
With regards to the 4 channel version not loading into a clipster i deleted the audio tracks in QT-Pro and it then loaded fine into Clipster.
Also if i view the movie properties in QT player, specificly the audio properties of the Sound Track the channel assignments are the following.
1 = center
2 = Left
3 = Right
4 = Center Surround
I’m not sure if this matters to anyone just thought I’d mention it.

I know @peter has been able to reproduce this now with some other test files we have. He has been looking into it in between fixing some other issues.

Hopefully we can get back to it soon and figure out what’s going on.

This issue should be fixed in the next beta release. As far as the channel assignments, the encoder we are using does not do discrete channels, but instead labels them as you indicated.

1 Like

Should be working now in build 4432!

Dave, I have confirmed that 2,4,6 channels all work without failure.
When i either AMA link or import the file in the Avid Channel 6 audio level is very low.
This track is tagged as LFE Screen in QT, changing the tagging before importing does not alter the levels.
Is cortex attempting to treat the track as LFE?
As noted before DVS Clipster will not load the 2 or 4 track versions I will see if i can have them tell me why.
I can send you and example if needed.

I think this is being done automagically by the library we are using for encoding the audio in this case.

I don’t think we need an example, but by all means you can ask DVS about their ability to load these files.

Is this feature useful to you as-is? Or are these issues you’re citing now critical to your workflow?

The 4 channel version is extremely helpful, we will steer clear of using 6 ch for now.

Correction to my previous post All files load into DVS clipster version
my previous attempts to load the file were in a beta version 5.9

1 Like