MOS clip - no silent audio rendered

OK, let me preface by saying this might seem counterintuitive, but it makes sense.

In my Deliverables tab I have an output to DNxHD 36. Audio is set to mix to channel 1. Now let’s say I have a clip with no audio attached; this is an MOS clip. In previous versions of Cortex, audio would be created in the form of a silent audio channel. But now in version 1.5 if there’s no audio attached, there simply is no audio file rendered.

I know this makes the most sense. If there’s no audio attached, why render a silent audio track. But the issue we have is later in our pipeline. Without going into specific details, we have a Digital Rapids encoder farm that is working with the DNxHD 36 files. The encoder software is looking for an audio track, even a silent one. Without an audio track, the encoders fail.

Is it possible to have an option in the Deliverable window to render silent audio even if no audio is attached? Just like it did in Cortex 1.4.4?

We had a number of users over the years specifically request that MOS clips not include any audio tracks, even if the audio mixer says otherwise, so I think we have to keep the current behavior as the default.

Currently, this special behavior applies only to DNxHD deliverables and only when the sound roll = “MOS”.

So one workaround would be to remove the audio from clips and then put something other than “MOS” in the sound roll field (you could leave it blank or set it to “NONE” for instance).

Would that be acceptable in your case?


Yeah, I think that will work. Knowing how this behavior is triggered should help us avoid it. Thanks!