Shared Project - clips in Reel don't show LUT symbol

So I created a new project, new shoot day. I opened it, then clicked Import > Cortex Manifest. The file imported and all the clips showed up. But I noticed the LUT symbol in the Status column was empty. (When the original manifest was saved, both an Input and Output LUT were added to each clip.) I clicked one clip and saw that there really was an Input and Output LUT applied to the clips, even though the status column said otherwise. For clarity, let’s call this clip “Clip 1”.

When I clicked on a different clip (“Clip 2”), then the LUT symbol for Clip 1 showed up in the status column. This continued for a bunch of the clips I tried. But when I closed then reopened the project, none of the clips had LUTs applied. When I clicked on a clip, none of the LUTs were applied now.

The bin looked like this as I clicked through the clips (notice the LUT cube symbol only showing up for some clips):

I’m going to email you the manifest XML file. By the way, this XML was created by right-clicking on a reel and exporting Cortex Manifest.

This is with Cortex 1.5.3 b5172

Thanks, we’ll take a look.

I’ve seen behavior like this before… a long time ago… hopefully it’s just a weird regression from a recent fix and we can resolve it quickly.

I’m suspecting that the changes made related to this are at fault:

@24pdailies - do you see either of these issues in the previous v1.5.3 release?

I haven’t tried importing a manifest before 1.5.3. I can give it a try with 1.5.2 and see what happens.

OK, there’s also a link to v1.5.3 b5126 that might work if I’m right about where this problem started: CORTEX v1.5.3 release notes

I haven’t been able to reproduce this, a couple of questions:

  • I guessed from your screenshot that you are importing the media first, then the Manifest, is that right?
  • I also guessed you are choosing to Import Reels
  • Do you see the LUTs show up in the merge dialog?

No, the media was not imported first. Empty project. Clips were added after import. Yes, reels were imported.

Ok, more info. If your database is local, then everything is ok. No issues. But if your database is on a shared database (MySQL) then the issue shows up.

For what it’s worth, we have MySQL Community Server 5.6 running on Win Server 2008.

1 Like

Hmmm… tried MySQL with an empty project and still can’t reproduce this. I did once see an error in the logs that looked like it could be related, but now I can’t make that happen either.

I tried using your manifest and one created here. LUTs are importing and sticking fine every time.

Server version: 5.6.13 MySQL Community Server (GPL)

Do you get any errors in the log when you import the manifest?

OK, I spent some time trying to nail down exactly what is happening and how to (hopefully) replicate it.

It appears to be more of a UI bug. But you can try these steps:

  1. Start a project on a shared database (Enterprise, MySQL)
  2. Add clips to project. Apply LUTs.
  3. Make a new reel and add the clips to the reel.
  4. Go to a different computer. Open the same project. Look in the Status column.

It seems that the major factors are A) if a clip has already been added to a reel and B) opening a shared project from a MySQL database.

This could possibly explain why I was seeing this issue when I imported the reel info from the manifest at the same time. I can go back and try importing without reels and see what happens.

One more thing - we’ve noticed this same UI behavior just sharing a project in 1.5.3 b5172 (so it’s not so much related to importing manifests as it is to sharing projects and having open reels).

Here’s what I’ve seen: Computer A started a project, imported clips, applied LUTs, added some (not all) clips to a reel. Computer B opened the project - the clips that were not in the reel had the LUT symbol. Clips that were not added to a reel yet did have the LUT symbol.

Edit: since this isn’t really related to importing manifests, I’m going to edit the discussion name.

I tried to reproduce that here, but didn’t have any luck. Do the clips that do not have the LUT symbol also not have the LUT applied on the other computer?

@peter - If computer A has the LUT applied (LUT symbol, color, etc) then I open the project on Computer B, the icon is not present on Computer B. The input/output LUT columns have a LUT name, but no symbol.

OK, I’m sorry if this seems like a problem on our end. Bear with me. Here’s what I do know:

  • the Input LUT and Output LUT names are appearing in shared projects (this is great, it means there’s a LUT name applied)
  • sometimes the LUT icon is not showing
  • when the LUT icon is not showing and the clip gets rendered, it gets rendered without color

And our setup: the project has the Stills/LUTs folder pointing to a folder on a shared StorNext volume, mounted as X: drive (so the path is actually X:/zzzz_Cortex_Stills_DO_NOT_DELETE ). Looking in this folder I can see the project and in the luts folder there’s two XML files named with UUID names (ie d2b60df8fa50000e848dda8f8090805c.xml).

When I open a project, there’s no LUT icon in the Status. When I click on a clip, there is color. Then when I click a different clip, the LUT icon shows up for the first clip.

There’s nothing in the log that says it couldn’t load LUT or anything.

I know this is really weird and hard to nail down. If you want to jump on via TeamViewer to see, I can set that up.

@24pdailies I don’t need to log in to see this, but to me it sounds like the color isn’t being saved properly on the first machine somehow. Could you send us a database snapshot along with the names of the clips that don’t have the LUT icons showing up on the second machine?

@peter - yes, I can prep a database and will send to you shortly. But I believe the color is being saved correctly.

I think I have a very simple way to replicate this on your end. Could you try these steps:

  1. New project on a shared database
  2. Import clips (I am using F55 XAVC 4K MXF).
  3. Apply Input and Output LUTs to all clips.
  4. Close the project
  5. Reopen the project. Look at the status column. Compare to the Input and Output LUT columns.

I think the reopening of the project is where things get dicey. This could explain why the 2nd computer is showing problems while the 1st is not. Also why it’s not being replicated easily.

Let me try that here before you send a database. I’ll get back to you shortly.

I tried those exact steps here and I have a LUT icon next to all 127 clips I imported, and the two LUT names in each column.

Yeah I can’t reproduce the problem here either.

Well thanks for trying. But I swear I’m not going crazy (that’s what you’d expect a crazy person to say though :smile:

It might be something to do with our setup and where the files are at on our network and such. Let me send you the database and stuff.

I do know (at least on our current setup) that if you open the project you’ll only see one or two clips with LUT icon, but the LUT names are in the columns. But if you start clicking on each clip, it “sees” that there should be LUTs, and when you click to a different clip, the LUT icon shows up in the previous clip. This actually “fixes” the issue; the next time you open the project the LUT icon shows up fine. (this might be, as peter said, the color isn’t being saved properly on the first machine)

But like I said, I’ll send you the database

Well, I can see the same thing you’re describing if I import your database. The LUT icon is missing from most clips, even though the columns show the LUT name for input and output.

Don’t understand much else yet, but we should be able to dig deeper with this.