Using REDROCKET-X for Debayer

Having mental block- How do we tell Cortex to use the REDROCKET-X for Debayer?

We selected it up in the Hardware tab at the top, have selected “For Playback” and “For Encoding”. No matter what we do we only get about 4-ish FPS Debayer in Cortex, which is the same as before it was installed. The Image Processor and Encode FPS are all 100+.

REDCine-X Sees it and chews through at multiple time faster than real time, depending on debayer res.

I know we are missing something silly. Any help is appreciated.

We are using 3.1.3.


  • Josh

Hi Josh,

I think that is all you need to do. I’ll check with the other developers on Monday and let you know for sure.

Hi Josh,

That should be all you need to do to enable the Red Rocket X. Can you send us the logs so we can see if they point to any problems?

Does it matter whether it is set to render or playback?

As a test, I would try just using it for render.

To follow up: when the computer has two GPUs and a RedRocket-X, one of the GPUs must be disabled, effectively using only one checked both for render and playback. Then the RedRocket-X will be available for use.

For that matter, it appears that the RedRocket-X card is substantially faster than trying to use two NVIDIA GTX 1080 8GB to do the debayering.

Thanks for the feedback Josh. We will see why you can only have one GPU enabled when using a RedReocket-X.