Tangent Devices Element Tk Panel, throwing many errors in log once connect button is clicked (Cortex Dailies 1.5.2b4771)

Hey Guys!

I bought a Tangent Element Tk panel and installed the drivers, rebooted, then opened Cortex Dailies v1.5.2b4771. I opened a project and went to the hardware page, selected “Element TK on USB” then hi “Connect”. Cortex seemed to freeze, and I noticed the Log button at the top right go red, and the error count shooting up in the thousands. After hitting disconnect and waiting a few minutes, I was able to look at the log. The entries were all the same,

" “0”,“Cortex”,“Error”,“Cortex//RunInternal(0): Panel thread failed: Specified argument was out of the range of valid values.
Parameter name: size”,"",“06-30-2014 18:33:28.167”,“10556”,“51”,“7113844611”,“DAILIES1” "

The error number was the only thing different. Any ideas? Did I forget something?

Thanks as always!

Is TangentHub.exe running in your process list?

Hmm… if its not running, you should actually get an error in the log simply telling you that, so that’s probably not it.

Another thing to check:

Open up C:\ProgramData\MTI\cortex.config. xml

You should see lines like this:

<?xml version="1.0" encoding="utf-8"?>
    <CurrentBay>Tangent Element</CurrentBay>
    <Bay Name="None" PanelType="None" />
    <Bay Name="Tangent Wave" PanelType="TangentWave" />
    <Bay Name="Tangent Element" PanelType="TangentElement" />

Make sure PanelType is TangentElement.

It might also be worth taking a look at this file:

C:\Program Files\MTI Film\Cortex_1_5_2_b4471\element-tk-map.xml

Despite its name, that file actually defines mapping to the controls for all the element panels now: Element-Mf, Element-Bt, Element-Kb, Element-Tk. I’m pretty sure that’s not an issue even if you only have one of those panels connected, but you could try removing the other sections and see if it helps (make a backup copy of the files first).

The process is running. Checking on the prior things right now.

Not seeing a C:\temp\cortex.config.xml

Is there anything in the map file I should be looking for? The Element-Tk section is in there…

Oh, sorry! I typed the wrong path. That file is here:

C:\ProgramData\MTI\cortex.config. xml

Found it, this is the entry within…

    <CurrentBay>ElementTK on USB</CurrentBay>
    <Bay Name="None" PanelType="None" />
    <Bay Name="Wave on USB" PanelType="TangentWave" />
    <Bay Name="ElementTK on USB" PanelType="TangentElement" />
    <Bay Name="Precision Panels" PanelType="Precision" IpAddress0="" IpAddress1="" IpAddress2="" />

That looks fine.

Can you try v1.5.1-b4772 and let us know if you have the same issue?

Upon opening V1.5.1-b4772 I get immediate entries into the log of:

"0","Cortex","Error","Cortex//DeserializeFromString(0): Error: Error in line 1 position 174. Element 'http://schemas.datacontract.org/2004/07/Render.Core.Pipeline:PipelineElement' contains data from a type that maps to the name 'http://schemas.datacontract.org/2004/07/Render.Core.Pipeline:FileNamingPipelineElement'. The deserializer has no knowledge of any type that maps to this name. Consider using a DataContractResolver or add the type corresponding to 'FileNamingPipelineElement' to the list of known types - for example, by using the KnownTypeAttribute attribute or by adding it to the list of known types passed to DataContractSerializer.","","07-01-2014 11:44:32.589","2616","1","184545157358","DAILIES1"

Upon hitting connect for the panel I get the same out of range error:

"0","Cortex","Error","Cortex//RunInternal(0): Panel thread failed: Specified argument was out of the range of valid values.
Parameter name: size","","07-01-2014 11:47:22.120","2616","45","185058381779","DAILIES1"

By the way, I’m using the newest download from tangent:


Sorry for posting in the wrong topic, bouncing around between a few tasks today…

So I may also be slow to respond.

Don’t worry! We’ll take a look and see as soon as we can

The first error you got running v1.5.1 is unrelated. It’s just complaining because the schema for the deliverable configs changed in v1.5.2 with the addition of the custom file naming feature.

I wanted you to try v1.5.1 just to make sure nothing broke for you when we made a few changes in v1.5.2 to allow you to adjust some sentitivities through the GUI, etc.

Looks like that’s not the issue.

I have an Element-Tk panel here and just tried it on my machine with the same Cortex build (v1.5.2-b4771) and the same version of TangentHub (v1.1.6). It’s working for me here, so it doesn’t look related to those versions.

Perhaps its a firewall setting?

My firewall is set up to explicitly allow connections to TangentHub on private networks:

That said, I haven’t been able to reproduce your issue yet by attempting to block those connections…

EDIT: For trouble shooting purposes perhaps you can try another application from this list that says “Hub Required” to see if its specific to Cortex or something else:

Not running a firewall, and Resolve seems to be working with the element-tk fine.

Would something in windows 8 have something to do with it?

Just tried to force hub to start with administrator privileges, didn’t fix it.

The MTI Film Cortex Dailies is showing up on the element’s display, fyi.

It could be a Windows 8 thing, not sure. Sounds like we need to dig deeper into what those log messages are trying to tell us.

I have about an hour and a cell lte connection if you’d like to teamviewer in.


Let me study of the code a bit first. What’s the availability like with the system this evening?

Unfortunately the building I’m in has nil for internet, except the lte from my phone. I can be here at some point tomorrow. Not sure what time yet… Thursday early AM could be a go though.

I’ll be here for a few more hours, plans changed

Can you email the today’s Cortex log to support?

lol, the log file is 5GB! I’ll it to the last session, cool?